Spring 框架对 JDK 版本的要求

Spring 版本对应的 JDK 版本

  • Spring Framework 5.3.x: JDK 8-17 (expected)
  • Spring Framework 5.2.x: JDK 8-15
  • Spring Framework 5.1.x: JDK 8-12
  • Spring Framework 5.0.x: JDK 8-10
  • Spring Framework 4.3.x: JDK 6-8

参考资料

官方说明:https://github.com/spring-projects/spring-framework/wiki/Spring-Framework-Versions